import re
regex = re.compile(r"(?P<v>截.*?股[份票\d,共计股万]+(.*(不存在|[占其]).*?(承诺|股[本份]).*?)?)[,。]", flags=re.MULTILINE)
test_str = "作。截至本公告披露日,郁琴芬女士持有本公司股份144,300,000股,占公司总股本的8.09%。郁琴芬及其一致行动人合计持有公司股份610,441,454股,占公司总股本的34.23%。"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")