const regex = /(?P<v>截.*?股[份票\d,共计股万]+(.*(不存在|[占其]).*?(承诺|股[本份]).*?)?)[,。]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<v>截.*?股[份票\\d,共计股万]+(.*(不存在|[占其]).*?(承诺|股[本份]).*?)?)[,。]', 'gm')
const str = `作。截至本公告披露日,郁琴芬女士持有本公司股份144,300,000股,占公司总股本的8.09%。郁琴芬及其一致行动人合计持有公司股份610,441,454股,占公司总股本的34.23%。`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}