using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(\w+)@([\w.]*:)?(\w+(?:\h\w+)*)(?!\S)";
string input = @"#1234 10% commet@timing:information and other activity2@timing
#12d34 10% commet@timing:information and other activity2@timing
#3132 10% testing@1.10:тестовый коммит frontend@44min:other comments
#3132 10% testing@1.10:тестовый коммит
#3132 10% testing@тестовый коммит
";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}