const regex = new RegExp('(?<!\\S)(\\w+)@([\\w.]*:)?(\\w+(?:\\h\\w+)*)(?!\\S)', 'ug')
const str = `#1234 10% commet@timing:information and other activity2@timing
#12d34 10% commet@timing:information and other activity2@timing
#3132 10% testing@1.10:тестовый коммит frontend@44min:other comments
#3132 10% testing@1.10:тестовый коммит
#3132 10% testing@тестовый коммит
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}