re = /(?<!\S)(\w+)@([\w.]*:)?(\w+(?:\h\w+)*)(?!\S)/
str = '#1234 10% commet@timing:information and other activity2@timing
#12d34 10% commet@timing:information and other activity2@timing
#3132 10% testing@1.10:тестовый коммит frontend@44min:other comments
#3132 10% testing@1.10:тестовый коммит
#3132 10% testing@тестовый коммит
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end