import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(\\w+)@([\\w.]*:)?(\\w+(?:\\h\\w+)*)(?!\\S)";
final String string = "#1234 10% commet@timing:information and other activity2@timing\n"
+ "#12d34 10% commet@timing:information and other activity2@timing\n"
+ "#3132 10% testing@1.10:тестовый коммит frontend@44min:other comments \n"
+ "#3132 10% testing@1.10:тестовый коммит \n"
+ "#3132 10% testing@тестовый коммит \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}