#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(?<!\S)(\w+)@([\w.]*)\:?(\w+(?:\h\w+)*)(?!\S)"
Local $sString = "#1234 10% activity@timing:information and other activity2@timing:adws" & @CRLF & _
"#3132 10% testing@1.10:test message frontend@44min:other comments " & @CRLF & _
"#3132 10% testing@1.10:test message " & @CRLF & _
"#3132 10% testing@1.10" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")