import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(\\w+)@([\\w.]*)\\:?(\\w+(?:\\h\\w+)*)(?!\\S)";
final String string = "#1234 10% activity@timing:information and other activity2@timing:adws\n"
+ "#3132 10% testing@1.10:test message frontend@44min:other comments \n"
+ "#3132 10% testing@1.10:test message \n"
+ "#3132 10% testing@1.10\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}