import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?<!\S)(\w+)@([\w.]*)\:?(\w+(?:\h\w+)*)(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
#1234 10% activity@timing:information and other activity2@timing:adws
#3132 10% testing@1.10:test message frontend@44min:other comments
#3132 10% testing@1.10:test message
#3132 10% testing@1.10
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)