using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(\w+)@([\w.]+)(?::([^@\n]+)(?!\S))?";
string input = @"#1234 10% activity@timing:information and other activity2@timing:adws
#3132 10% testing@1.10:test message frontend@44min:other comments
#3132 10% testing@1.10:test message
#3132 10% testing@1.10
";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}