import re
regex = re.compile(r"(?<!\S)(\w+)@([\w.]+)(?::([^@\n]+)(?!\S))?", flags=re.UNICODE)
test_str = ("#1234 10% activity@timing:information and other activity2@timing:adws\n"
"#3132 10% testing@1.10:test message frontend@44min:other comments \n"
"#3132 10% testing@1.10:test message \n"
"#3132 10% testing@1.10\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")