$re = '~(?<!\S)(\w+)@([\w.]+)(?::([^@\n]+)(?!\S))?~u';
$str = '#1234 10% activity@timing:information and other activity2@timing:adws
#3132 10% testing@1.10:test message frontend@44min:other comments
#3132 10% testing@1.10:test message
#3132 10% testing@1.10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);