re = /(?<!\S)(\w+)@([\w.]+)(?::([^@\n]+)(?!\S))?/
str = '#1234 10% activity@timing:information and other activity2@timing:adws
#3132 10% testing@1.10:test message frontend@44min:other comments
#3132 10% testing@1.10:test message
#3132 10% testing@1.10
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end