const regex = new RegExp('(?P<name>[A-ZÀ-Ÿ\\s-\\.\\/\\(\\)\\'\\/]+)(?:\\s)*(?P<dosage>(?:[\\d\\s]+(?:ml|ML|mg|MG|g|%)*[\\s/]*)*)(?:\\s)(?P<adminmode2>[A-ZÀ-Ÿ\\s-\\.\\/\\(\\)\\'\\/]*)(?P<separator>,|\\.\\s\\/)(?:\\s)(?P<adminmode1>[a-zA-ZÀ-ÿ\\s\\(\\)\\-\\'\\.0-9]+)', 'gm')
const str = `CALMANTE VITAMINADO PEREZGIMENEZ COMPRIMIDOS , 200 comprimidos`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}