// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<name>[A-ZÀ-Ÿ\s-\.\/\(\)'\/]+)(?:\s)*(?P<dosage>(?:[\d\s]+(?:ml|ML|mg|MG|g|%)*[\s/]*)*)(?:\s)(?P<adminmode2>[A-ZÀ-Ÿ\s-\.\/\(\)'\/]*)(?P<separator>,|\.\s\/)(?:\s)(?P<adminmode1>[a-zA-ZÀ-ÿ\s\(\)\-'\.0-9]+)").unwrap();
let string = "CALMANTE VITAMINADO PEREZGIMENEZ COMPRIMIDOS , 200 comprimidos";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}