$re = '`(?P<name>[A-ZÀ-Ÿ\s-\.\/\(\)\'\/]+)(?:\s)*(?P<dosage>(?:[\d\s]+(?:ml|ML|mg|MG|g|%)*[\s/]*)*)(?:\s)(?P<adminmode2>[A-ZÀ-Ÿ\s-\.\/\(\)\'\/]*)(?P<separator>,|\.\s\/)(?:\s)(?P<adminmode1>[a-zA-ZÀ-ÿ\s\(\)\-\'\.0-9]+)`m';
$str = 'CALMANTE VITAMINADO PEREZGIMENEZ COMPRIMIDOS , 200 comprimidos';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);