re = /(?P<name>[A-ZÀ-Ÿ\s-\.\/\(\)'\/]+)(?:\s)*(?P<dosage>(?:[\d\s]+(?:ml|ML|mg|MG|g|%)*[\s\/]*)*)(?:\s)(?P<adminmode2>[A-ZÀ-Ÿ\s-\.\/\(\)'\/]*)(?P<separator>,|\.\s\/)(?:\s)(?P<adminmode1>[a-zA-ZÀ-ÿ\s\(\)\-'\.0-9]+)/m
str = 'CALMANTE VITAMINADO PEREZGIMENEZ COMPRIMIDOS , 200 comprimidos'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end