package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)PASSWORD\(\:\)`)
var str = `# Match this, is exact
PASSWORD(:)
#Not same case (lowercase vs uppercase)
Password(:)
#No semi-colon
PASSWORD()`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}