re = /PASSWORD\(\:\)/m
str = '# Match this, is exact
PASSWORD(:)
#Not same case (lowercase vs uppercase)
Password(:)
#No semi-colon
PASSWORD()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end