# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(a)\b(?!.*\b\1\b)/KKK/gm;t' <<< "a a b b a c b d aa"