$re = '/\b(a)\b(?!.*\b\1\b)/m';
$str = 'a a b b a c b d aa';
$subst = "KKK";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;