#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(a)\b(?!.*\b\1\b)"
Local $sString = "a a b b a c b d aa"
Local $sSubst = "KKK"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)