import Foundation
let pattern = #"\b(a)\b(?!.*\b\1\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"a a b b a c b d aa"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"KKK"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)