using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(screen_name:\s+\S)(\S*)(\S)";
string substitution = @"\1****\3";
string input = @"screen_name: jack
screen_name: mack
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}