$re = '/(screen_name:\s+\S)(\S*)(\S)/';
$str = 'screen_name: jack
screen_name: mack
';
$subst = "\1****\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;