const regex = /(screen_name:\s+\S)(\S*)(\S)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(screen_name:\\s+\\S)(\\S*)(\\S)', 'g')
const str = `screen_name: jack
screen_name: mack
`;
const subst = `\1****\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);