import re
regex = re.compile(r"(screen_name:\s+\S)(\S*)(\S)")
test_str = ("screen_name: jack\n"
"screen_name: mack\n")
subst = "\\1****\\3"
result = regex.sub(subst, test_str)
if result:
print(result)