#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b"
Local $sString = "0_0" & @CRLF & _
"" & @CRLF & _
"____-_" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"____ - _" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" - s" & @CRLF & _
"so-" & @CRLF & _
" -so" & @CRLF & _
"s-o" & @CRLF & _
"~-®" & @CRLF & _
"" & @CRLF & _
"The -soner" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"“The captain wore his cap and cape proudly as" & @CRLF & _
"he sat listening to the recap of how his" & @CRLF & _
"crew saved the men from a capsized vessel." & @CRLF & _
"”" & @CRLF & _
"" & @CRLF & _
"Excerpt From: Ben Forta. “Learning Regular Expressions.” iBooks. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")