// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b").unwrap();
let string = "0_0
____-_
____ - _
- s
so-
-so
s-o
~-®
The -soner
“The captain wore his cap and cape proudly as
he sat listening to the recap of how his
crew saved the men from a capsized vessel.
”
Excerpt From: Ben Forta. “Learning Regular Expressions.” iBooks. ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}