const regex = /\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b', 'gm')
const str = `0_0
____-_
____ - _
- s
so-
-so
s-o
~-®
The -soner
“The captain wore his cap and cape proudly as
he sat listening to the recap of how his
crew saved the men from a capsized vessel.
”
Excerpt From: Ben Forta. “Learning Regular Expressions.” iBooks. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}