import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b";
final String string = "0_0\n\n"
+ "____-_\n\n\n"
+ "____ - _\n\n\n"
+ " - s\n"
+ "so-\n"
+ " -so\n"
+ "s-o\n"
+ "~-®\n\n"
+ "The -soner\n\n\n"
+ "“The captain wore his cap and cape proudly as\n"
+ "he sat listening to the recap of how his\n"
+ "crew saved the men from a capsized vessel.\n"
+ "”\n\n"
+ "Excerpt From: Ben Forta. “Learning Regular Expressions.” iBooks. ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}