import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z][a-zA-Z0-9-.]+@[a-zA-Z-]+\\.(com|edu|net)";
final String string = "'2abcdefghijklmnopqrcdtuvxyz'\n"
+ "'ABCDEFGHIJKLMNOPQRSTUVXYZ'\n"
+ "'0123456789'\n\n"
+ "'0988184106', '0911184106'\n\n"
+ "'0222573153'\n"
+ "'02 2257 3153'\n"
+ "2/June/2018\n"
+ "3:24:23.45\n\n"
+ "leeyuyi1950@gmail.com\n\n"
+ "Mr. Schafer\n"
+ "Mr Smith\n"
+ "Ms David\n"
+ "Mrs. Robison\n"
+ "Mr. T\n"
+ " \n"
+ "Leeyuyi@yahoo.com\n"
+ "mss.friend123@google.net\n"
+ "wang-321n-wu@kuo-university.edu\n\n"
+ "word /dboundaries odd\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}