import Foundation
let pattern = #"[a-zA-Z][a-zA-Z0-9-.]+@[a-zA-Z-]+\.(com|edu|net)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
'2abcdefghijklmnopqrcdtuvxyz'
'ABCDEFGHIJKLMNOPQRSTUVXYZ'
'0123456789'
'0988184106', '0911184106'
'0222573153'
'02 2257 3153'
2/June/2018
3:24:23.45
leeyuyi1950@gmail.com
Mr. Schafer
Mr Smith
Ms David
Mrs. Robison
Mr. T
Leeyuyi@yahoo.com
mss.friend123@google.net
wang-321n-wu@kuo-university.edu
word /dboundaries odd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)