# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n/|/igm;t' <<< "Data od klienta 1.řádek
Data od klienta 2.řádek
Data od klienta 3.řádek"