use strict;
my $str = 'Data od klienta 1.řádek
Data od klienta 2.řádek
Data od klienta 3.řádek';
my $regex = qr/\n/imp;
my $subst = '|';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";