// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)\n").unwrap();
let string = "Data od klienta 1.řádek
Data od klienta 2.řádek
Data od klienta 3.řádek";
let substitution = "|";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}