re = /\n/im
str = 'Data od klienta 1.řádek
Data od klienta 2.řádek
Data od klienta 3.řádek'
subst = '|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result