package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^a-zA-Z][a-zA-Z]{1,2}$`)
var str = `ny12345d
ny12345dc
ny12346T01
ny12346dfA
ny12345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}