$re = '/[^a-zA-Z][a-zA-Z]{1,2}$/m';
$str = 'ny12345d
ny12345dc
ny12346T01
ny12346dfA
ny12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);