re = /[^a-zA-Z][a-zA-Z]{1,2}$/m
str = 'ny12345d
ny12345dc
ny12346T01
ny12346dfA
ny12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end