import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*kafka.producer:.*,client-id=.*,node-id=(?<node_id>[\\w\\s-\\d]*)\\/(in.?[\\w\\s-\\d]*)\\(.*\\) == (?<rate>[\\d.]*)";
final String string = "2020-12-02 13:16:33.695325.kafka.producer:type=producer-node-metrics,client-id=confluent-event-logger,node-id=node-2/incoming-byte-rate(None) == 9.16456607850198";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}