$re = '/.*kafka.producer:.*,client-id=.*,node-id=(?<node_id>[\w\s-\d]*)\/(in.?[\w\s-\d]*)\(.*\) == (?<rate>[\d.]*)/m';
$str = '2020-12-02 13:16:33.695325.kafka.producer:type=producer-node-metrics,client-id=confluent-event-logger,node-id=node-2/incoming-byte-rate(None) == 9.16456607850198';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);