use strict;
my $str = '2020-12-02 13:16:33.695325.kafka.producer:type=producer-node-metrics,client-id=confluent-event-logger,node-id=node-2/incoming-byte-rate(None) == 9.16456607850198';
my $regex = qr/.*kafka.producer:.*,client-id=.*,node-id=(?<node_id>[\w\s-\d]*)\/(in.?[\w\s-\d]*)\(.*\) == (?<rate>[\d.]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}