import Foundation
let pattern = #".*kafka.producer:.*,client-id=.*,node-id=(?<node_id>[\w\s-\d]*)\/(in.?[\w\s-\d]*)\(.*\) == (?<rate>[\d.]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2020-12-02 13:16:33.695325.kafka.producer:type=producer-node-metrics,client-id=confluent-event-logger,node-id=node-2/incoming-byte-rate(None) == 9.16456607850198"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)