package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\w:\s?)([^:]+)\s(\w:\s?)([^:]+)(\s|$))`)
var str = `p: perguntaA r: respostaA p: perguntaB r: respostaB p: perguntaC r: respostaC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}