re = /((\w:\s?)([^:]+)\s(\w:\s?)([^:]+)(\s|$))/
str = 'p: perguntaA r: respostaA p: perguntaB r: respostaB p: perguntaC r: respostaC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end