using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w-]+\.\w+";
string input = @"/storage/emulated/0/text.mp3
/storage/emulated/0/text2.mp3
/storage/emulated/0/text.mp3
/storage/emulated/0/DeliveryThing.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}