re = /[\w-]+\.\w+/m
str = '/storage/emulated/0/text.mp3
/storage/emulated/0/text2.mp3
/storage/emulated/0/text.mp3
/storage/emulated/0/DeliveryThing.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end