// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\w-]+\.\w+").unwrap();
let string = "/storage/emulated/0/text.mp3
/storage/emulated/0/text2.mp3
/storage/emulated/0/text.mp3
/storage/emulated/0/DeliveryThing.txt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}