package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\w-]+\.\w+`)
var str = `/storage/emulated/0/text.mp3
/storage/emulated/0/text2.mp3
/storage/emulated/0/text.mp3
/storage/emulated/0/DeliveryThing.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}